Mikrotik Memisah Bandwidth IIX dan International dan Bandwidth Manajemen


Skenario:
internet — ip public:ether1-gateway:Mikrotik RB750:ether2-master-local:192.168.99.1 — clients:192.168.99.x/24

I. Memisah bandwidth IIX dan Internasional

-Download script nice.rsc dari http://ixp.mikrotik.co.id/download/nice.rsc
-Via Winbox => New Terminal ketik

/tool fetch address=ixp.mikrotik.co.id src-path=/download/nice.rsc mode=http;


-Import nice.rsc ke system mikrotik

import nice.rsc

-Hasil import script nice.rsc akan terlihat di menu winbox IP => Firewall => Address Lists

 
II. Setup bandwidth management secara otomatis membagi per ip address
-Setup firewall mangle,menandai paket IIX dan International

/ip firewall mangle
add action=mark-packet chain=forward disabled=no dst-address-list=nice \
new-packet-mark=packet-ip-iix passthrough=no
add action=mark-packet chain=forward disabled=no dst-address-list=!nice \
new-packet-mark=packet-ip-intl passthrough=no

 
-Setup Queue type
-pcq-rate=0 agar mikrotik mengatur automatic jumlah bandwidth yang dipakai, jadi semisal hanya 1 user yg online bisa memakai bandwidth sesuai aturan di simple queue di parameter max-limit
-Upload pcq-classifier=src-address ; Download pcq-classifier=dst-address

/queue type
add kind=pcq name=pcq-upload pcq-burst-rate=0 pcq-burst-threshold=0 \
    pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask
    pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-m
    pcq-src-address6-mask=64 pcq-total-limit=2000
add kind=pcq name=pcq-download pcq-burst-rate=0 pcq-burst-threshold=0 
    pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask
    pcq-dst-address6-mask=64 pcq-limit=50 pcq-rate=0 pcq-src-address-m
    pcq-src-address6-mask=64 pcq-total-limit=2000

 
-Setup Simple Queue
Contoh: Melimit max-limit=upload/download=290k/900k untuk paket yang telah di-mark di firewall mangle

/queue simple
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=0/0 max-limit=290k/900k name=que-iix \
    packet-marks=packet-ip-iix parent=none priority=8 queue=\
    pcq-upload/pcq-download target-addresses=192.168.99.0/24 total-queue=\
    default-small
add burst-limit=0/0 burst-threshold=0/0 burst-time=0s/0s direction=both \
    disabled=no interface=all limit-at=0/0 max-limit=290k/900k name=que-intl \
    packet-marks=packet-ip-intl parent=none priority=8 queue=\
    pcq-upload/pcq-download target-addresses=192.168.99.0/24 total-queue=\
    default-small

 
III. Testing:
3 Virtual Box download dari www.filehippo.com (link international)

 
References:
http://www.mikrotik.co.id/artikel_lihat.php?id=23
http://wiki.mikrotik.com/wiki/Category:Manual

Leave a Reply

Your email address will not be published. Required fields are marked *