Setup VPN PPTP server on Mikrotik


Skenario:
VPN clients(192.168.90.2-10) — eth1(public ip):mikrotik:eth2(LAN 192.168.99.1) — LAN Clients (192.168.99.x/24)

System:
-Mikrotik RB750 RouterOS v5.20

I. Create pool ip address for VPN clients ip address
Example create pool for 9 VPN clients with ip address 192.168.90.2-192.168.90.10

/ip pool
add name=vpn-pool ranges=192.168.90.2-192.168.90.10


 
II. Create VPN profile

/ppp profile
add change-tcp-mss=yes dns-server=192.168.99.5,192.168.99.6 local-address=\
    192.168.90.1 name=vpn-profile only-one=default remote-address=vpn-pool \
    use-compression=default use-encryption=yes use-mpls=default \
    use-vj-compression=default

 
III. Create PPTP server interface

/interface pptp-server server
set authentication=mschap1,mschap2 default-profile=vpn-profile enabled=yes \
    keepalive-timeout=30 max-mru=1460 max-mtu=1460 mrru=disabled

/interface pptp-server
add disabled=no name=pptp-vpn-server user=""

 
IV. Create VPN users login

/ppp secret
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=bachem \
    password=adadeh profile=vpn-profile routes="" service=pptp
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=tempe \
    password=adadeh profile=vpn-profile routes="" service=pptp
add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=tahu \
    password=adadeh profile=vpn-profile routes="" service=pptp

 
V. Test connect Windows 7 machine from internet





Mikrotik Log:

 
References:
http://wiki.mikrotik.com/wiki/Manual:Interface/PPTP
http://wispwatchers.com/node/3

Related posts:

7 thoughts on “Setup VPN PPTP server on Mikrotik

  1. edisonch

    I arrived to the same result as your MS DOS’s screenshot including the 0.0.0.0 gateway. I can’t get anywhere after get connected. I only able to ping the vpn gateway but unable to ping others clients behind the vpn gateway. There must be missing steps ?

    Reply
  2. Sendze Martin

    Hello have this question can it be configured without having a public ip address help me out with the instructions if possible we could talk privately. Thanks

    Reply
  3. Ndzelen Martin Sendze

    Hello have this question can it be configured without having a public ip address help me out with the instructions if possible we could talk privately.

    Reply
  4. FirstTisha

    I have noticed you don’t monetize your page, don’t waste your traffic,
    you can earn extra cash every month because you’ve got high quality content.
    If you want to know how to make extra $$$, search for: Mrdalekjd methods for $$$

    Reply
  5. BrodieSmall

    I have checked your blog and i have found some duplicate content, that’s why you don’t rank high in google, but there is a tool that
    can help you to create 100% unique articles, search
    for; Boorfe’s tips unlimited content

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *